Práctica de Redes

Configuración IPv6

Configuremos una red de computadoras como el escenario mostrado, usando direccionamiento ipv6 y Cisco Packet Tracer.

IPv6 basic1.pkt

 

Se usa un escenario con el direccionamiento IPv6 para aplicar el mismo con diferentes protocolos de ruteo.

Entonces guarde el archivo con el direccionamiento y cuando configure el protocolo de ruteo guárdelo con otro nombre, uno para cada tipo.

Al usar los archivos de ejercicio actualice a un escenario duplicando la red.

Configuración ejemplo:

enable

conf t

ipv6 unicast-routing

ipv6 router rip rip

 

interface FastEthernet1/0

ipv6 rip rip enable

 

no ipv6 rip rip default-information originate

 

exit

 

Comandos de configuración protocolo RIP, en parte global, habilitar ruteo y protocolo RIP.

En cada interface habilitar el ruteo para el dominio o proceso

Revise la tabla de ruteo, si el protocolo es RIP no se requiere redistribuir las rutas.

 

 

Antes de iniciar a configurar:

Debe seleccionar adecuadamente el router por las interfaces que soporta

 

Al hacer una copia se tiene que modificar muchos datos.

El dato del display para switches y routers no es el nombre del dispositivo.

 

Se llega a las rutas por la IP de destino no por la interface, por lo que no se usa una ruta para las redes locales solo las otras.

 

ipv6 route 2001:DB8:A0B:12F0::/64 2001:DB8:A0B:12F4::1

ipv6 route 2001:DB8:A0B:12F1::/64 2001:DB8:A0B:12F4::1

 

ipv6 route 2001:DB8:A0B:12F2::/64 2001:DB8:A0B:12F4::2

ipv6 route 2001:DB8:A0B:12F3::/64 2001:DB8:A0B:12F4::2

 

ipv6 route 2001:DB8:A0B:12F5::/64 2001:DB8:A0B:12F4::3

ipv6 route 2001:DB8:A0B:12F6::/64 2001:DB8:A0B:12F4::3

 

ipv6 route 2001:DB8:A0B:12F7::/64 2001:DB8:A0B:12F4::4

ipv6 route 2001:DB8:A0B:12F8::/64 2001:DB8:A0B:12F4::4

 

 

Al duplicar la red e interconectar, una solución para este escenario es colocar un Switch en el centro.

 

La solución depende de la distribución en el modelo físico.

 

Permite el crecimiento de la red de forma simple, con el switch, el cable cambia de cruzado a recto (straight).

 

La red central se conoce como multipunto y las interfaces forman parte de la misma red.

 

Para probar la conectividad a todos los dispositivos es realizar un ping a los destinos.

 

 

 

 

Al presionar Click sobre los dispositivos se abre la ventana de dialogo, tiene las pestañas: “Física”, “Config” y “CLI”.

 

 

Para el router, seleccione Física:

 

Podrá ver una representación del dispositivo, cómo es y está configurado.

Configurado:

4 interfaces FastEthernet/IEEE 802.3

4 interfaces de red network serial Low-speed (sync/async)

Físicamente observamos una interface inalámbrica con dos antenas, en la descripción de arranque no se muestran.

 

En la pestaña CLI, por medio de la interface de comandos, el dispositivo presenta mensajes escritos en la pantalla de terminal y por el teclado se escriben las órdenes.

 

La siguiente son secciones de la información del sistema (IOS) obtenidas de CLI, cuando el equipo “arranca”, inicia con la verificación de los componentes, memoria y sistema y presenta los siguientes que para entenderlos se agrupan en las partes:

 

  1. A) Físico: Configuración del dispositivo en este escenario:

4 interfaces LAN, 4 interfaces WAN, 1 interface Wireless.

Configuración estandar=  2 interfaces LAN, Puerto de consola y auxialiar, slot (ranura) Memoria Compact Flash, Fuente de energía CA y CD (opcional), 2 slots USB.

 

 

  1. B) Versión del Sistema (Cisco Packet Tracer)

System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

Copyright (c) 2000 by cisco Systems, Inc.

Cisco 2811 (MPC860) processor (revision 0x200) with 60416K/5120K bytes of memory

 

  1. C) Arranque:

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M),

Version 12.4(15)T1, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Wed 18-Jul-07 06:21 by pt_rel_team

Image text-base: 0x400A925C, data-base: 0x4372CE20

 

  1. D) Cifrado:

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

Sending email to export@cisco.com.

 

 

  1. E) Componentes:

Processor board ID JAD05190MTZ (4292891495)

M860 processor: part number 0, mask 49

4 FastEthernet/IEEE 802.3 interface(s)

4 Low-speed serial(sync/async) network interface(s)

239K bytes of non-volatile configuration memory.

62720K bytes of  ATA CompactFlash (Read/Write)

 

  1. F) Notas:
  2. Puertos o interfaces de Switch, no soportan ruteo de tráfico.

 

 

 

Mensajes de Estado:

%LINK-5-CHANGED: Interface Dot11Radio0/2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0/2/0, changed state to up

 

%LINK-5-CHANGED: Interface Dot11Radio0/2/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0/2/1, changed state to up

 

%LINK-5-CHANGED: Interface Dot11Radio0/2/0, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0/2/0, changed state to down

 

%LINK-5-CHANGED: Interface Dot11Radio0/2/1, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0/2/1, changed state to down

 

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

 

%LINK-5-CHANGED: Interface Vlan1, changed state to up

 

%LINK-5-CHANGED: Interface Dot11Radio0/2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0/2/0, changed state to up

%LINK-5-CHANGED: Interface Dot11Radio0/2/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0/2/1, changed state to up

 

%LINK-5-CHANGED: Interface FastEthernet1/1, changed state to up

 

%LINK-5-CHANGED: Interface Dot11Radio0/2/0, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0/2/0, changed state to down

 

%LINK-5-CHANGED: Interface Dot11Radio0/2/1, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0/2/1, changed state to down

 

%LINK-5-CHANGED: Interface FastEthernet1/1, changed state to administratively down

%LINK-5-CHANGED: Interface Vlan1, changed state to administratively down

 

%SYS-5-CONFIG_I: Configured from console by console

 

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up

 

Router#

sh ip int brief

 

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset up up
FastEthernet0/1 unassigned YES unset up up
Serial0/0/0 unassigned YES unset administratively down down
Serial0/0/1 unassigned YES unset administratively down down
Serial0/1/0 unassigned YES unset administratively down down
Serial0/1/1 unassigned YES unset administratively down down
Dot11Radio0/2/0 unassigned YES unset administratively down down
Dot11Radio0/2/1 unassigned YES unset administratively down down
FastEthernet1/0 unassigned YES unset up up
FastEthernet1/1 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down

 

El mismo informe cambia para ipv6:

Router# sh ipv6 int brief

FastEthernet0/0            [up/up]

FE80::2E0:F7FF:FE66:1A4

2001:DB8:A0B:12F0::255

FastEthernet0/1            [up/up]

FE80::210:11FF:FE06:9251

2001:DB8:A0B:12F1::255

2001:DB8:A0B:12F1:210:11FF:FE06:9251

Serial0/0/0                [administratively down/down]

Serial0/0/1                [administratively down/down]

Serial0/1/0                [administratively down/down]

Serial0/1/1                [administratively down/down]

Dot11Radio0/2/0            [administratively down/down]

Dot11Radio0/2/1            [administratively down/down]

FastEthernet1/0            [up/up]

FE80::20C:85FF:FE06:E4B4

2001:DB8:A0B:12F4::1

FastEthernet1/1        [administratively down/down]

Vlan1                        [administratively down/down]

 

  1. ¿Qué significa “administratively down”? en el estado de la interface.

 

  1. Significa que la interface está apagada, por lo común las interfaces del Router vienen apagadas mientras que en el Switch vienen encendidas. Estatus UP, encendida, protocolo UP conectado.

 

Para este ejercicio las direcciones asignadas son IPv6, para IPv4 no se configuraron.

 

Configuración de Ruteo EIGRP

 

enable

conf t

 

ipv6 unicast-routing

 

 

ipv6 router eigrp 10

eigrp router-id 1.1.1.1

no shutdown

 

Se requiere establecer el identificador del router.

La configuración Global de Ruteo, no activa la difusión de la red, ahora se realiza por interface.

 

interface FastEthernet1/0

ipv6 eigrp 10

 

interface FastEthernet0/0

no ipv6 rip rip enable

 

interface FastEthernet1/0

no ipv6 rip rip enable

 

En ambos routers se debe establecer la conexión mediante el mismo router-id.

 

 

 

 

Tabla de Ruteo en ambos routers:

 

Encabezado de la table de ruteo  
Codes:

C – Connected, L – Local, S – Static, R – RIP, B – BGP, U – Per-user Static route,

M – MIPv6, I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary

O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2

ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2, D – EIGRP, EX – EIGRP external

 

Códigos representan el protocol identificado
   
Router#sh ipv6 route  
IPv6 Routing Table – 10 entries

 

C   2001:DB8:A0B:12F0::/64 [0/0]            via ::, FastEthernet0/0

L   2001:DB8:A0B:12F0::255/128 [0/0]      via ::, FastEthernet0/0

C   2001:DB8:A0B:12F1::/64 [0/0]            via ::, FastEthernet0/1

L   2001:DB8:A0B:12F1::255/128 [0/0]       via ::, FastEthernet0/1

L   2001:DB8:A0B:12F1:210:11FF:FE06:9251/128 [0/0]     via ::, FastEthernet0/1

D   2001:DB8:A0B:12F2::/64 [90/30720]    via FE80::290:21FF:FE3D:339C, FastEthernet1/0

D   2001:DB8:A0B:12F3::/64 [90/30720]    via FE80::290:21FF:FE3D:339C, FastEthernet1/0

C   2001:DB8:A0B:12F4::/64 [0/0]             via ::, FastEthernet1/0

L   2001:DB8:A0B:12F4::1/128 [0/0]          via ::, FastEthernet1/0

L   FF00::/8 [0/0]                                      via ::, Null0

 
   
Router#sh ipv6 route  
IPv6 Routing Table – 9 entries

 

D   2001:DB8:A0B:12F0::/64 [90/30720]   via FE80::20C:85FF:FE06:E4B4, FastEthernet1/0

D   2001:DB8:A0B:12F1::/64 [90/30720]   via FE80::20C:85FF:FE06:E4B4, FastEthernet1/0

C   2001:DB8:A0B:12F2::/64 [0/0]            via ::, FastEthernet0/0

L   2001:DB8:A0B:12F2::255/128 [0/0]      via ::, FastEthernet0/0

C   2001:DB8:A0B:12F3::/64 [0/0]            via ::, FastEthernet0/1

L   2001:DB8:A0B:12F3::255/128 [0/0]      via ::, FastEthernet0/1

C   2001:DB8:A0B:12F4::/64 [0/0]             via ::, FastEthernet1/0

L   2001:DB8:A0B:12F4::2/128 [0/0]          via ::, FastEthernet1/0

L   FF00::/8 [0/0]      via ::, Null0

 

 

 

 

Router(config)# ipv6 router eigrp 10

 

Router(config-rtr)# ?

exit          Exit from routing protocol configuration mode

metric        Modify EIGRP routing metrics and parameters

no            Negate a command or set its defaults

redistribute  Redistribute IPv6 prefixes from another routing protocol

router-id     router-id for this EIGRP process

shutdown      Shutdown protocol

 

 

Comandos de configuración de Interface:

 

Router(config)# interface FastEthernet1/0

Router(config-if)#?

 

arp                  Set arp type (arpa, probe, snap) or timeout

bandwidth       Set bandwidth informational parameter

cdp                 CDP interface subcommands

crypto              Encryption/Decryption commands

custom-queue-list  Assign a custom queue list to an interface

delay               Specify interface throughput delay

description      Interface specific description

duplex             Configure duplex operation.

exit                   Exit from interface configuration mode

fair-queue        Enable Fair Queuing on an Interface

hold-queue       Set hold queue depth

ip                      Interface Internet Protocol config commands

ipv6                  IPv6 interface subcommands

mac-address        Manually set interface MAC address

mtu                   Set the interface Maximum Transmission Unit (MTU)

no                     Negate a command or set its defaults

pppoe               pppoe interface subcommands

priority-group     Assign a priority group to an interface

service-policy     Configure QoS Service Policy

shutdown           Shutdown the selected interface

speed                Configure speed operation.

tx-ring-limit        Configure PA level transmit ring limit

 

Configuración de IPV6 para la interface:

Router(config-if)# ipv6 ?

 

address          Configure IPv6 address on interface

dhcp               IPv6 DHCP interface subcommands

eigrp              Configure EIGRP IPv6 on interface

enable            Enable IPv6 on interface

hello-interval   Configures IP-EIGRP hello interval

mtu                  Set IPv6 Maximum Transmission Unit

nat                   Enable IPv6 NAT on interface

nd                    Network discovery

ospf                 OSPF interface commands

rip                    Configure RIP routing protocol

summary-address  Summary prefix

traffic-filter       Access control list for packets

 

 

 

 

 

Para configurar ruteo OSPF

Habilitado ruteo para IPv6:

 

enable

conf t

 

ipv6 unicast-routing

 

Router(config)#

ipv6 router ospf 10

%OSPFv3-4-NORTRID: OSPFv3 process 10 could not pick a router-id,please configure manually

router-id 1.1.1.1

 

Establecer el área

Se requiere establecer el identificador del router, diferente para cada router.

area 11 default-cost 115

 

La configuración Global de Ruteo, no activa la difusión de la red, ahora se realiza por interface.

 

interface FastEthernet1/0

ipv6 ospf 10 area 11

 

interface FastEthernet0/0

ipv6 ospf 10 area 11

 

interface FastEthernet1/0

ipv6 ospf 10 area 11

 

En ambos routers se debe establecer la conexión mediante diferente router-id.

 

00:44:40: %OSPFv3-5-ADJCHG: Process 10, Nbr 1.1.1.1 on FastEthernet1/0 from LOADING to FULL, Loading Done

 

Se tenía mismo router-id, entonces:

Reload or use “clear ipv6 ospf process” command, for this to take effect

Router(config-rtr)#

 

 

Nota: si existe un error es bueno re iniciar el (los) equipo(s)

 

Router 0
C 2001:DB8:A0B:12F0::/64 [0/0]     via ::, FastEthernet0/0

L 2001:DB8:A0B:12F0::255/128 [0/0] via ::, FastEthernet0/0

C 2001:DB8:A0B:12F1::/64 [0/0]     via ::, FastEthernet0/1

L 2001:DB8:A0B:12F1::255/128 [0/0] via ::, FastEthernet0/1

L 2001:DB8:A0B:12F1:210:11FF:FE06:9251/128 [0/0] via ::, FastEthernet0/1

O 2001:DB8:A0B:12F2::/64 [110/2]   via FE80::290:21FF:FE3D:339C, FastEthernet1/0

O 2001:DB8:A0B:12F3::/64 [110/2]   via FE80::290:21FF:FE3D:339C, FastEthernet1/0

C 2001:DB8:A0B:12F4::/64 [0/0]     via ::, FastEthernet1/0

L 2001:DB8:A0B:12F4::1/128 [0/0]   via ::, FastEthernet1/0

L FF00::/8 [0/0]     via ::, Null0

 

 

 

 

Hay varios ejemplos en internet, en las siguiente página se presenta la configuración.

 

Fuente Práctica:

https://community.cisco.com/t5/blogs-routing-y-switching/configurar-ripng/ba-p/3099864

Habilite el reenvío de tráfico IPv6 con el comando ipv6 unicast-routing, de lo contrario presenta error.

RIPng se habilita en la interfaz en vez del modo global de configuración, ya que no existe el comando network, se habilita RIPng en la interfaz donde se desea publicar la red con el comando ipv6 rip domain-name enable, aplicar a todas las interfaces del router que pertenezcan al mismo proceso y que se deseen publicar aunque no estén conectadas con otra.

Proceso o domain-name puede ser número o palabra. Puede ser este identificador el mismo o diferente en toda la red RIP.

Ejemplo de configuración RIPng para la siguiente topología, construya el escenario siguiente y configure direccionamiento ipv6.

E:\users\guido\myWorks\01_utn\05_Asignaturas\Redes\eBooks\news

RIPng+pkt6.2sv.pkt

Configure la velocidad de reloj (clock rate) en el R3, es DCE en 64000.

 

Comando para configurar RIPng

ipv6 rip id1 enable

id1 nombre del dominio al que pertenecerán cada interfaz que se quiera publicar:

Lo mismo con todas las demás interfaces faltantes

  • R1 –> Fa 0/1
  • R2 –> Fa 0/0 y Se 0/0/0
  • R3 –> Fa 0/1 y Se 0/0/0

 

R3#sh run R2#sh run
   
Building configuration…

 

Current configuration : 820 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R3

!

!

!

!

!

!

!

!

no ip cef

ipv6 unicast-routing

!

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

ipv6 address 2001:A:A:B::6/64

ipv6 rip id_1 enable

!

interface Serial0/0/0

no ip address

ipv6 address 2001:A:A:A::5/64

ipv6 rip id_1 enable

clock rate 64000

!

interface Serial0/1/0

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

ipv6 router rip id_1

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Building configuration…

 

Current configuration : 802 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R2

!

!

!

!

!

!

!

!

no ip cef

ipv6 unicast-routing

!

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

ipv6 address 2001:A:A:C::6/64

ipv6 rip id_1 enable

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

no ip address

ipv6 address 2001:A:A:A::6/64

ipv6 rip id_1 enable

!

interface Serial0/1/0

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

ipv6 router rip id_1

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

   
   
R1#sh run  
Building configuration…

 

Current configuration : 799 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R1

!

!

!

!

!

!

!

!

no ip cef

ipv6 unicast-routing

!

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

ipv6 address 2001:A:A:C::5/64

ipv6 rip id_1 enable

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

ipv6 address 2001:A:A:B::5/64

!

interface Serial0/0/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/1/0

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

ipv6 router rip id_1

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

Cuando configura RIPng en todas las interfaces de los routers, en la tabla de enrutamiento se presentan las rutas.

La práctica para descargar de: http://ipv6curso.890m.com/, de la sección “Configurar RIPng”, autor: Daniely Flores.  ripng.zip

R2# sh ipv6 route
  IPv6 Routing Table – 6 entries

Codes:

C – Connected, L – Local, S – Static, R – RIP, B – BGP

U – Per-user Static route, M – MIPv6, I1 – ISIS L1,ccI2 – ISIS L2,

IA – ISIS interarea, IS – ISIS summary, O – OSPF intra,

OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2, ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2, D – EIGRP, EX – EIGRP external

 

 

C 2001:A:A:A::/64 [0/0] via ::, Serial0/0/0

L 2001:A:A:A::6/128 [0/0] via ::, Serial0/0/0

R 2001:A:A:B::/64 [120/2] via FE80::230:A3FF:FEAC:DC01, Serial0/0/0

 

C 2001:A:A:C::/64 [0/0] via ::, FastEthernet0/0

L 2001:A:A:C::6/128 [0/0] via ::, FastEthernet0/0

L FF00::/8 [0/0] via ::, Null0

 

   
R1#sh ipv6 route
  IPv6 Routing Table – 6 entries

Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP

U – Per-user Static route, M – MIPv6, I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary, O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2, ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2

D – EIGRP, EX – EIGRP external

 

R 2001:A:A:A::/64 [120/2]

via FE80::2E0:A3FF:FE22:C601, FastEthernet0/0

C 2001:A:A:B::/64 [0/0]

via ::, FastEthernet0/1

L 2001:A:A:B::5/128 [0/0]

via ::, FastEthernet0/1

C 2001:A:A:C::/64 [0/0]

via ::, FastEthernet0/0

L 2001:A:A:C::5/128 [0/0]

via ::, FastEthernet0/0

L FF00::/8 [0/0]

via ::, Null0

   
   

 

Remoción de RIP:

 

enable

conf t

 

no ipv6 router rip rip

 

interface FastEthernet1/0

no ipv6 rip rip enable

 

interface FastEthernet0/0

no ipv6 rip rip enable

 

interface FastEthernet1/0

no ipv6 rip rip enable

 

 

Direccionamiento básico con IPv6 + RIPng

July 13, 2011

http://www.redescisco.net/sitio/2011/07/13/direccionamiento-basico-con-ipv6-ripng/

Cuando se habla de configurar IPv6 pensamos en esas inmensas direcciones IP, IPv6 ofrece una sencillez respecto a IPv4 en configuraciones de enrutamiento complejas, simplificando estas tareas.

En este artículo se muestra una configuración básica de IPv6 y enrutamiento RIPng (RIP New Generation), ejercicio similar al anterior, por lo que antes de revisar las instrucciones, se sugiere lo intente, vea que lo que se agrega son las redes LAN IPv6.

En la topología se tienen 3 Routers y dos redes LAN se conectan mediante direccionamiento IPv6. Los bloques asignados están escritos y para simplificar la configuración se han dejado todos en /64.

Paso 1: Configuramos las direcciones IP en cada interfaz de cada router.

R1

R1(config)#
R1(config)#int s0/0
R1(config-if)#ipv6 address 2001:A:A:A::5/64
R1(config-if)#no shutdown
R1(config-if)#int f0/0
R1(config-if)#ipv6 address 2001:A:A:C::5/64
R1(config-if)#no shutdown
R1(config-if)#int f0/1
R1(config-if)#ipv6 address 2001:0:0:1::1/64
R1(config-if)#no shutdown
R1(config-if)#

 

R2

R2(config)#
R2(config)#int s0/0
R2(config-if)#ipv6 address 2001:A:A:A::6/64
R2(config-if)#no shutdown
R2(config-if)#int f0/0
R2(config-if)#ipv6 address 2001:A:A:B::5/64
R2(config-if)#no shutdown
R2(config-if)#int f0/1
R2(config-if)#ipv6 address 2001::2:0:0:0:1/64
R2(config-if)#no shutdown
R2(config-if)#

R3

R3(config)#int f0/0
R3(config-if)#ipv6 address 2001:A:A:C::6/64
R3(config-if)#no shutdown
R3(config-if)#int f0/1
R3(config-if)#ipv6 address 2001:A:A:B::6/64
R3(config-if)#no shutdown
R3(config-if)#

Probar que exista ping entre los enlaces:

R1# ping ipv6 2001:A:A:A::6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:A:A:A::6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/32/68 ms
R1#ping ipv6 2001:A:A:C::6Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:A:A:C::6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/33/60 ms
R1#

Lo mismo para los demás Routers.

Asignado el direccionamiento IPv6 básico, enrutar al igual que en IPv4, cada router conoce redes y hosts conectadas directamente.

El enrutamiento IPv4 e IPv6 viene desactivado de manera predeterminada, activar en todos los routers. El comando de modo global es ipv6 unicast-routing (similar a ip routing).

R1(config)#ipv6 unicast-routing

R2(config)#ipv6 unicast-routing

R3(config)#ipv6 unicast-routing

Nota: Se requiere aún para una ruta estática.

Para habilitar RIPng ingrese a la interfaz de router donde se desea publicar con el comando ipv6 rip IDENTIFICADOR  enable. Donde “IDENTIFICADOR” es una palabra o número de proceso, semejante al estilo de OSPF.

Ingrese en todas las interfaces de R1, R2 y R3 este comando.

Nota: La interfaz f0/1 de R1 y R3 no conectan a otro router, se debe habilitar RIPng para que esas redes se publiquen.

R1(config)#int f0/0
R1(config-if)#ipv6 rip REDESCISCO enable
R1(config-if)#int f0/1
R1(config-if)#ipv6 rip REDESCISCO enable
R1(config-if)#int s0/0
R1(config-if)#ipv6 rip REDESCISCO enable
R1(config-if)#end

 

R2(config)#int f0/0
R2(config-if)#ipv6 rip REDESCISCO enable
R2(config-if)#int f0/1
R2(config-if)#ipv6 rip REDESCISCO enable
R2(config-if)#int s0/0
R2(config-if)#ipv6 rip REDESCISCO enable
R2(config-if)#end

 

R3(config)#int f0/0
R3(config-if)#ipv6 rip REDESCISCO enable
R3(config-if)#int f0/1
R3(config-if)#ipv6 rip REDESCISCO enable
R3(config-if)#end

NOTA: El nombre de proceso no debe ser el mismo en todos los routers, es un identificador local, puede ser el mismo o diferente en toda la red RIP, el enrutamiento funcionará igualmente. En el router es necesario que todas las interfaces pertenezcan al mismo proceso.

¿Comando network?. RIPng se ha optimizado, al igual que OSPFv3 e EIGRPv6 para simplificar la configuración en la declaración de redes. En IPv6 si quiere publicar una red es necesario ingresar a la interfaz y habilitar el protocolo de enrutamiento requerido. No hay que declarar redes utilizando el comando network.

La tabla de enrutamiento se ha actualizado con las redes aprendidas por RIPng.

Para ver la tabla de enrutamiento en IPv6 el comando es show ipv6 route.

Para R3:

R3#show ipv6 route
IPv6 Routing Table – 7 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
U – Per-user Static route, M – MIPv6
I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
D – EIGRP, EX – EIGRP external


R 2001:0:0:1::/64 [120/2]
via FE80::C200:3FF:FE10:0, FastEthernet0/0
R 2001:0:0:2::/64 [120/2]
via FE80::C201:3FF:FE10:0, FastEthernet0/1
R 2001:A:A:A::/64 [120/2]
via FE80::C200:3FF:FE10:0, FastEthernet0/0
C 2001:A:A:B::/64 [0/0]
via ::, FastEthernet0/1
C 2001:A:A:C::/64 [0/0]
via ::, FastEthernet0/0
L 2001:A:A:C::6/128 [0/0]
via ::, FastEthernet0/0
L FF00::/8 [0/0]
via ::, Null0
R3#

Las redes identificadas con R han sido aprendidas mediante RIP.

Prueba de conexión envíe ping de R1 a R3.

R1#ping ipv6 2001::2:0:0:0:1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/64/100 ms
R1#

Desafío usa la misma topología, configura OSPFv3.

CiscoNetworking

About Paulo Colomés

Ingeniero y consultor especialista en infraestructura y operaciones de redes. Instructor Cisco certificado CCNA R&S, CCDA, CCNA Security, CCNP R&S, ITQ, entre otros. Fundador de REDESCISCO.NET y Netlearning Academy (www.netlearning.cl)

 

 

 

Enrutamiento para IPv6.

 

Ruta Estática Enrutamiento dinámico
  Directamente conectado   RIPng
  Totalmente especificado   OSPFv3
  Flotante   EIGRP for IPV6
  Por defecto   MP-BGPv4 (Multiprocolo BGP)
       

 

Ruta estática directamente conectada IPv6

Router(config)#

 

 

Para el Ruteo Estático:

 

Static Routing

La Syntax es:

ipv6 route ipv6-prefix/prefix-length  ipv6-address

 

[administrative-distance]
 Interface-type number [ipv6-address]

 

  • Una ruta estática directamente conectada es creada cuando especificamos la interface de salida.

o   Parámetros:

  • interface-type number especifica el interface a través del cuál la red destino se alcanza.
  • ipv6-prefix/prefix-length identifica la red de destino IPv6 y su prefijo de longitud.

 

 

Ejemplo:

ipv6 route 2001:DB8::/64 2001:DB8:2:1::1 150

 

Explicación:

Routes packets for network 2001:db8::/64 to a networking device at 2001:DB8:2:1::1 with an administrative distance of 150

 

Ruta default:

ipv6 route ::/0 2001:DB8:0:1::2

 

Router#

conf t

Enter configuration commands, one per line.  End with CNTL/Z.

 

Router(config)#

no ipv6 route 2001:DB8:A0B:12F3::/64 FastEthernet1/0

no ipv6 route 2001:DB8:A0B:12F2::/64 FastEthernet1/0

ipv6 route 2001:DB8:A0B:12F2::/64 2001:DB8:A0B:12F4::2

ipv6 route 2001:DB8:A0B:12F3::/64 2001:DB8:A0B:12F4::2

 

Router(config)#

ping 2001:DB8:A0B:12F3::255

^

% Invalid input detected at ‘^’ marker.

 

do ping 2001:DB8:A0B:12F3::255

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001:DB8:A0B:12F3::255, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 19/32/47 ms

 

Nota:  Es conveniente usar la dirección IP destino en vez de definir la salida por la interface.

 

 

 

 

Dynamic Routing Protocols in IPv6

 

  • Ruteo Dinámico en IPv6 sin cambios de IPv4:

o   IPv6 tiene 2 tipos de protocolos de ruteo: IGP and EGP

o   IPv6 usa el algorithm  de ruteo de longest-prefix match

  • Los protocolos deruteo interno IGP

o   RIPng (RFC 2080)

o   Cisco EIGRP for IPv6

o   OSPFv3 (RFC 5340)

o   Integrated IS-ISv6 (RFC 5308)

  • Los protocolos deruteo externo EGP

o   MP-BGP4 (RFC 4760 and RFC 2545)

 

 

 

Para Configurar los Protocolos de Ruteo

  • Los protocolos de ruteo Dinámico requieren un router-id

o   Router-id es un entero único 32 bit para el router

o   IOS auto-genera sus direcciones de interface de loopback si se configuró, en otro caso la dirección IPv4 más alta del router

o   La mayoría de ISPs proveeran IPv6 dual stack , de manera que el router-id se crea automáticamente

  • Early adopters choosing to deploy IPv6 in the total absence of any IPv4 addressing need to be aware:

o   Router-id needs to be manually configured:

  • ipv6 router ospf 100
  • router-id 10.1.1.4

 

from:

04-IPv6-routing.pdf

E:\users\guido\myWorks\01_utn\05_Asignaturas\Redes\eBooks\news

E:\users\guido\proyectos\Cisco_PacketTracer\saves5.3.3\saves

 

 

 

DHCPv6

 

DHCPv6 – Dynamic Host Configuration Protocol para IPv6

 

El DHCPv6 es similar a su antecesor en IPv4.

La diferencia entre DHCP para IPv4 y para IPv6, es en IPv4 un único método de configuración, en IPv6 tenemos dos métodos:

 

Métodos del DHCPv6

 

  1. A) Stateful – el servidor en IPv4 e IPv6 guardan un histórico de las configuraciones que entrega al cliente, y cada una de las direcciones que el equipo recibió.
  2. B) Stateless – Este es un nuevo método, se origina con IPv6, el servidor no guarda el histórico de direcciones asignadas y provee los parámetros adicionales comunes al hosts.

 

Configuración Stateful

 

DHCPV6 (config)#

ipv6 dhcp pool STATEFUL

STATEFUL es el nombre para ese grupo de direcciones.

 

DHCPV6 (config-dhcpv6)#

address prefix 2001:1111:1111:1111::/64

La dirección es el valor fijo que maneja el grupo

 

DHCPV6 (config-dhcpv6)#

dns-server 2001:4860:4860::8888

 

DHCPV6 (config-dhcpv6)#

domain-name NETWORKLESSONS.LOCAL

nombre del dominio

 

 

IPv6 basic1+static+x2+dhcp6.pkt

El ejercicio presentado esta desarrollado en Packet Tracer v5.3.3

 

Configuración DHCP en el dispositivo, verifique que su sistema tenga instalado IPv6.

La Versión Cisco Packet Tracer 5.3.3 y más recientes lo soportan, hay cambios de funcionalidad (programación) tanto en sistemas operativos reales como en Cisco Packet Tracer.

Una vez activo DHCP para IPv6, seleccione la interfaz y debió cambiar  a configuración DHCP para la dirección.

 

 

Servidor DNS

Ipv6=  2001:DB8:A0B:12F0::200/64

 

 

ipv6 dhcp pool 12f0

prefix-delegation pool local

dns-server 2001:DB8:A0B:12F0::200

domain-name utnlab.edu

 

ipv6 local pool local 2001:db8:a0b:12f0::400/64 64

La dirección ipv6/leng identifica el rango inicial por asignar.

 

En la interface:

ipv6 dhcp server 12f0

 

Al conectar un dispositivo Cliente DHCP, verificar el funcionamiento local.

 

 

Router(config)#

ipv6 dhcp pool local

 

Router(config-dhcp)#?

dns-server           DNS servers

domain-name      Domain name to complete unqualified host names

exit                      Exit from DHCPv6 configuration mode

no                        Negate a command or set its defaults

prefix-delegation  IPv6 prefix delegation

 

domain-name utnlab.edu

 

IPv6 prefix delegation

 

Router(config-dhcp)#

pref ?

X:X:X:X::X/<0-128>  IPv6 x:x:y/<z>

pool                IPv6 prefix pool

 

Router(config-dhcp)#pref 2001:DB8:A0B:12F0::1:0/64 ?

WORD  DHCPv6 unique identifier (DUID)

Router(config-dhcp)#pref 2001:DB8:A0B:12F0::1:0/64 12f0 ?

lifetime  Configure prefix lifetimes

<cr>

Router(config-dhcp)#pref 2001:DB8:A0B:12F0::1:0/64 12f0

%Invalid DUID format

Router(config-dhcp)#pref 2001:DB8:A0B:12F0::1:/64 12f0

^

% Invalid input detected at ‘^’ marker.

 

Router(config-dhcp)#pref 2001:DB8:A0B:12F0:0:0:1:/64 12f0

^

% Invalid input detected at ‘^’ marker.

 

Router(config-dhcp)#pref 2001:DB8:A0B:12F0::/64 12f0

%Invalid DUID format

Router(config-dhcp)#

 

Router(config)#

ipv6 local pool local 2001:db8:a0b:12f0::/64

% Incomplete command.

 

ipv6 local pool local 2001:db8:a0b:12f0::/64 ?

<0-128>  Prefix length to assign from pool

 

ipv6 local pool local 2001:db8:a0b:12f0::/64 64

% Pool is reserved by IPv6 Address

 

ipv6 local pool local 2001:db8:a0b:12f0::400/64 64

è Comando complete.

 

 

   
R1#show run  
ipv6 unicast-routing Habilita ruteo para ipv6
   
!  
ipv6 dhcp pool CISCO Define el servidor dhcpv6 CISCO
prefix-delegation pool LOCAL-HOSTS Designación del pool al servidor
dns-server AAAA:BBBB:CCCC:DDDD::FFFF  
domain-name cisco.com Nombre del dominio
!  
ipv6 local pool LOCAL-HOSTS 2001:A:A:A::/64 64 Asignación del rango para pool local
!  
interface FastEthernet0/0  
no ip address  
duplex auto  
speed auto  
ipv6 address FE80::1 link-local  
ipv6 address 2001:A:A:A::1/64 Dirección IPv6 de la interface
ipv6 nd managed-config-flag  
ipv6 dhcp server CISCO Asignación del server DHCPv6

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s